<!DOCTYPE html> <html> <head> <meta charset="utf-8"> <meta http-equiv="X-UA-Compatible" content="IE=edge"> <meta name="viewport" content="width=device-width, initial-scale=1"> <title> Learning CSS Grids </title> <link rel="canonical" href="http://varun.ca/css-grid/"> <meta name="description" content="finder of new ways to confuse myself"> <link rel="author" href="humans.txt"> <link rel="apple-touch-icon" sizes="180x180" href="http://varun.ca/apple-touch-icon.png"> <link rel="icon" type="image/png" href="http://varun.ca/favicon-32x32.png" sizes="32x32"> <link rel="icon" type="image/png" href="http://varun.ca/favicon-16x16.png" sizes="16x16"> <link rel="manifest" href="http://varun.ca/manifest.json"> <link rel="mask-icon" href="http://varun.ca/safari-pinned-tab.svg" color="#4e4bec"> <meta name="theme-color" content="#ffffff"> <style>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</style> </head> <body> <nav class="border-box center ph3 mt6 flex-ns system-sans f6 lh-solid mw7"> <a href="http://varun.ca/writing" class="mid-gray ma0 mr2 link b ttu tracked dib dim"> Varun Vachhar </a> <p class="light-silver ma0 tracked"> finder of new ways to confuse myself </p> </nav> <article class="mw7 center ph3 mv6 dark-gray"> <header class="system-sans mb6"> <date class="f6 gray" datetime="2017-05-16 00:00:00 +0000"> 16th May, 2017 </date> <h1 class="f3 f2-m f1-ns mt1"> Learning CSS Grids </h1> </header> <!-- post content --> <div class="f5 f4-ns lh-copy nested" id="js-post-content"> <figure class="center pa0 flex justify-center bg-white"><pre class="mv0 lh-solid code bg-white">
+-------------------------+ +---+
|                         | |   |
|  CSS Grid               | |   |
|  Layout Module          | |   |
|                         | |   |
+-------------------------+ |   |
+----+ +------------------+ |   |
|    | |                  | |   |
|    | |                  | |   |
|    | +------------------+ +---+
|    | +------+ +---------------+
|    | |      | |               |
+----+ +------+ +---------------+</pre></figure> <p>CSS Grid is here! As of March 2017, all major browsers support it. Given this good news I decided to spend some time to better understand how to use it. The learning curve was much steeper than I expected – the module introduces something like 17 new concepts. It was quite overwhelming to take it all in, so I started breaking things down, taking notes and making demos, which I am going to share here. This is by no means an exhaustive guide. It might not even be 100% factually correct. But this should be enough information for you to form a basic mental model of how CSS Grids work and start building layouts with it.</p> <h2 id="terminology">Terminology</h2> <p>Before we start creating grid layouts we need to learn a few new terms. A <strong>Grid Container</strong> is an element on which <code class="highlighter-rouge">display: grid</code> has been applied. All its direct descendants become <strong>Grid Items</strong>.</p> <p>When we define the grid we specify the number of rows and columns we want. The grid layout system then generates numbered lines which divide the grid horizontally and vertically. These are known as <strong>Grid Lines</strong>. The space between any two adjacent grid lines is called <strong>Grid Track</strong>. This is essentially a generic term for <em>columns</em> and <em>rows</em>.</p> <figure class="center pa0 flex justify-around flex-wrap bg-tertiary"><pre class="mv0 f6 lh-solid code">
Grid Lines


+---+---+---+---+---+---+ 1
|   |   |   |   |   |   |
|   |   |   |   |   |   |
|   |   |   |   |   |   |
+-------+---+-----------+ 2
|   |xxx|   |   |   |   |
|   |xxx|&lt;-- Grid Cell  |
|   |xxx|   |   |   |   |
+-----------------------+ 3
|   |   |   |   |   |   |
|   |   |   |   |   |   |
|   |   |   |   |   |   |
+---+---+---+---+---+---+ 4
1   2   3   4   5   6   7</pre><pre class="mv0 f6 lh-solid code">
Row Tracks


+---+---+---+---+---+---+
|xxxxxxxxxxxxxxxxxxxxxxx|
|xxxxxxxxxxxxxxxxxxxxxxx|
|xxxxxxxxxxxxxxxxxxxxxxx|
+-----------------------+
|   |   |   |   |   |   |
|   |   |   |   |   |   |
|   |   |   |   |   |   |
+-----------------------+
|   |   |   |   |   |   |
|   |   |   |   |   |   |
|   |   |   |   |   |   |
+---+---+---+---+---+---+</pre><pre class="mv0 f6 lh-solid code">
Column Tracks


+---+---+---+---+---+---+
|xxx|   |   |   |   |   |
|xxx|   |   |   |   |   |
|xxx|   |   |   |   |   |
+xxx--------------------+
|xxx|   |   |   |   |   |
|xxx|   |   |   |   |   |
|xxx|   |   |   |   |   |
+xxx--------------------+
|xxx|   |   |   |   |   |
|xxx|   |   |   |   |   |
|xxx|   |   |   |   |   |
+---+---+---+---+---+---+</pre><figcaption class="clip">The grid gives us numbered lines to use when positioning items. A grid track is the space between any two lines on the grid.</figcaption> </figure> <p>A <strong>Grid Cell</strong> is the smallest unit on the grid. It is the intersection of a row and column. Conceptually it is quite similar to a table cell.</p> <p><strong>Grid Area</strong> is the space created by the intersection of four grid lines. In other words, it is a collection of one or more adjacent grid cells. ⚠️ Grid area can only be rectangular! It is not possible to create T- or L-shaped grid areas. Which for some reason was the first thing I wanted to do.</p> <figure class="center pa0 flex justify-center bg-tertiary"><pre class="mv0 f6 lh-solid code">
Grid Area


+---+---+---+---+---+---+
|   |   |   |   |   |   |
|   |   |   |   |   |   |
|   |   |   |   |   |   |
+---+---+-----------+---+
|   |   |xxxxxxxxxxx|   |
|   |   |xxxxxxxxxxx|   |
|   |   |xxxxxxxxxxx|   |
+---+---|xxxxxxxxxxx|---+
|   |   |xxxxxxxxxxx|   |
|   |   |xxxxxxxxxxx|   |
|   |   |xxxxxxxxxxx|   |
+---+---+-----------+---+</pre><figcaption class="clip">Grid items can span one or more cells – by row or by column – this is called a grid area.</figcaption> </figure> <h2 id="defining-a-grid">Defining a Grid</h2> <p>There are many different ways to define a grid. I’m going to start by focusing on a basic scenario: 4 columns x 5 rows. <code class="highlighter-rouge">grid-template-rows</code> &amp; <code class="highlighter-rouge">grid-template-columns</code> allow us to define the count and sizing of rows and columns respectively. We can list out the tracks as shown in the example below.</p> <figure class="center pa0 flex justify-around flex-wrap bg-tertiary"><pre class="mv0 f6 lh-copy code">
.my-grid-container {
  display: grid;
  grid-template-columns: 20px 20px 20px 20px;
  grid-template-rows: 20px 20px 20px 20px 20px;
}
</pre><pre class="mv0 f6 lh-solid code">
.my-grid-container
+---+----+----+----+-------------+
|   |    |    |    |             |
|   |    |    |    |             |
+---+----+----+----+             |
|   |    |    |    |             |
|   |    |    |    |             |
+---+----+----+----+             |
|   |    |    |    |             |
|   |    |    |    |             |
+---+----+----+----+             |
|   |    |    |    |             |
|   |    |    |    |             |
+---+----+----+----+             |
|   |    |    |    |             |
|   |    |    |    |             |
+---+----+----+----+             |
|                                |
|                                |
|                                |
|                                |
+--------------------------------+</pre><figcaption class="clip">A basic grid with 4 columns and 5 rows. The rows are defined using grid-template-rows and columns using grid-template-columns.</figcaption> </figure> <p>We have a grid ✅ Not the most useful grid ever, but a grid nonetheless. In the above example, each row is <code class="highlighter-rouge">20px</code> tall and each column is <code class="highlighter-rouge">20px</code> wide. The one thing to note here is that <code class="highlighter-rouge">grid-template-rows</code> &amp; <code class="highlighter-rouge">grid-template-columns</code> allow us to define the grid tracks. The browser then generates the grid lines automatically. These lines are invisible. They are there to help us with positing items on the grid, but do not impact our design visually. That said, being able to see these lines is extremely helpful for debugging. Luckily for us Firefox has a built-in <a href="https://www.mozilla.org/en-US/developer/css-grid">Grid Inspector</a> which visualizes the grid for us 🙌🏽</p> <p>In this example, the grid has fixed track sizes. Which is a fancy way of saying that rows and/or columns have fixed widths. Therefore, the grid will remain the same size regardless of how big/small the container is.</p> <h3 id="flexible-grids">Flexible Grids</h3> <p>We can also define grids with flexible track sizes. Or even have both fixed and flexible tracks at the same time! (See the example below.) Here percentage values refer to a percentage of the grid container.</p> <figure class="center pa0 flex justify-around flex-wrap bg-tertiary"><pre class="mv0 f6 lh-copy code">
.my-weird-but-flexible-grid {
  display: grid;
  grid-template-columns: 20px 5% 80px 40%;
  grid-template-rows: 4rem 2vh 12% 80px 20em;
}
</pre><pre class="mv0 f6 lh-solid code">
.my-weird-but-flexible-grid

+-+--+----+----------------------+
| |  |    |                 |    |
+-+--+----+-----------------+    |
+-+--+----+-----------------+    |
| |  |    |                 |    |
| |  |    |                 |    |
+-+--+----+-----------------+    |
| |  |    |                 |    |
+-+--+----+-----------------+    |
| |  |    |                 |    |
| |  |    |                 |    |
| |  |    |                 |    |
| |  |    |                 |    |
| |  |    |                 |    |
+-+--+----+-----------------+    |
|                                |
|                                |
|                                |
|                                |
|                                |
+--------------------------------+
</pre><figcaption class="clip">A flexible grid where we are using a mixture of units for track measurements such as, pixels, percentage, viewport units and ems.</figcaption> </figure> <h3 id="the-fr-unit">The fr Unit</h3> <p>Let’s look at another example of a flexible grid. In this case we are still building a 4x5 grid, but we want the rows and columns to stretch out and fill the entire container. To do this, we will use the <code class="highlighter-rouge">fr</code> unit.</p> <p>At this point you are probably asking yourself. <em>The what unit?</em> 🤷🏽‍♂️</p> <figure class="center pa0 flex justify-around flex-wrap bg-tertiary"><pre class="mv0 f6 lh-copy code">
.my-grid {
  display: grid;
  grid-template-columns: 1fr 1fr 1fr 1fr;
  grid-template-rows: 1fr 1fr 1fr 1fr 1fr;

  /*
  The above can also be written as:
    grid-template-columns: repeat(4, 1fr);
    grid-template-rows: repeat(5, 1fr);
  */
}
</pre><pre class="mv0 f6 lh-solid code">
.my-grid

+------+------+------+------+
|      |      |      |      |
|      |      |      |      |
|      |      |      |      |
+------+------+------+------+
|      |      |      |      |
|      |      |      |      |
|      |      |      |      |
+------+------+------+------+
|      |      |      |      |
|      |      |      |      |
|      |      |      |      |
+------+------+------+------+
|      |      |      |      |
|      |      |      |      |
|      |      |      |      |
+------+------+------+------+
|      |      |      |      |
|      |      |      |      |
|      |      |      |      |
+------+------+------+------+</pre><figcaption class="clip">A flexible grid with 4 columns and 5 rows. It is made flexible by setting the rows and columns to 1fr.</figcaption> </figure> <p>We have a new unit! The <code class="highlighter-rouge">fr</code> unit represents a fraction of the available space in the grid container. Have you ever used <code class="highlighter-rouge">flex: 1</code> &amp; <code class="highlighter-rouge">flex: 2</code>, etc? This works exactly like that. You can specify track sizing as a ratio of free space, eg: <code class="highlighter-rouge">1fr 2fr</code>.</p> <p>📝 We can define track sizing as length, percentage or <code class="highlighter-rouge">fr</code>.</p> <h3 id="gutters">Gutters</h3> <p>It wouldn’t be a real grid without some gutters. For this we can use <code class="highlighter-rouge">grid-column-gap</code> and <code class="highlighter-rouge">grid-row-gap</code> properties, or the shorthand <code class="highlighter-rouge">grid-gap</code>. The grid only generates gutters between the tracks. There is no gutter before the first track or after the last track.</p> <p>⚠️ Even though there is a gap between two adjacent tracks there is still only one grid line.</p> <figure class="center pa0 flex justify-around flex-wrap bg-tertiary"><pre class="mv0 f6 lh-copy code">
.my-grid {
  display: grid;
  grid-template-columns: 1fr 1fr 1fr 1fr;
  grid-template-rows: 1fr 1fr 1fr 1fr 1fr;
  grid-gap: 1rem;
}
</pre><pre class="mv0 f6 lh-solid code">
.my-grid


1     2      3      4     5
+----+-+----+-+----+-+----+ 1
|    | |    | |    | |    |
|    | |    | |    | |    |
+----+ +----+ +----+ +----+
+----+ +----+ +----+ +----+ 2
|    | |    | |    | |    |
|    | |    | |    | |    |
+----+ +----+ +----+ +----+
+----+ +----+ +----+ +----+ 3
|    | |    | |    | |    |
|    | |    | |    | |    |
+----+ +----+ +----+ +----+
+----+ +----+ +----+ +----+ 4
|    | |    | |    | |    |
|    | |    | |    | |    |
+----+ +----+ +----+ +----+
+----+ +----+ +----+ +----+ 5
|    | |    | |    | |    |
|    | |    | |    | |    |
+----+-+----+-+----+-+----+ 6</pre><figcaption class="clip">A flexible 4x5 grid with gutters. Gutters can be created by using grid-gap property.</figcaption> </figure> <h2 id="positioning-grid-items">Positioning Grid Items</h2> <p>Now that we have defined a grid, let’s explore some options for how to place items on it. Much like flexbox, grid placement is not dependent on source order. This allows us to create complex layouts that can be drastically re-arranged using media queries. More on that later. Let’s focus on some basics for now.</p> <p>Positioning items on a grid is quite similar to using absolute positioning. Except, instead of specifying locations in measurement units we specify start and end grid lines.</p> <figure class="center pa0 flex justify-center bg-tertiary"><pre class="mv0 f6 lh-solid code">
                      .my-grid

                      1     2      3      4     5
                      +----+-+----+-+----+-+----+ 1
                      |    | |    | |    | |    |
                      |    | |    | |    | |    |
                      |    | |    | |    | |    |
   grid-row-start (2)-------------&gt; o-----------o &lt;-----(5) grid-column-end
grid-column-start (3) |    | |    | |xxxxxxxxxxx|
                      |    | |    | |xxxxxxxxxxx|
                      |    | |    | |xxxxxxxxxxx|
                      +----+ +----+ |xxxxxxxxxxx|
                      |    | |    | |xxxxxxxxxxx|
                      |    | |    | |xxxxxxxxxxx|
                      |    | |    | |xxxxxxxxxxx|
grid-row-end (4)------------------&gt; o-----------o 4
                      |    | |    | |    | |    |
                      |    | |    | |    | |    |
                      |    | |    | |    | |    |
                      +----+ +----+ +----+ +----+ 5
                      |    | |    | |    | |    |
                      |    | |    | |    | |    |
                      |    | |    | |    | |    |
                      +----+-+----+-+----+-+----+ 6</pre><figcaption class="clip">We can position items on the grid using grid-column-start, grid-column-end and grid-row-start, grid-row-end.</figcaption> </figure> <p>Grid lines are automatically numbered. Starting with <code class="highlighter-rouge">1</code> for the topmost and leftmost lines. We use these numbers to declare <code class="highlighter-rouge">grid-column-start</code> / <code class="highlighter-rouge">grid-column-end</code> and <code class="highlighter-rouge">grid-row-start</code> / <code class="highlighter-rouge">grid-row-end</code>. We can also start counting from the end. For that we start with <code class="highlighter-rouge">-1</code> for the rightmost and topmost lines. Lastly, we can also specify these locations as spans. For example, <code class="highlighter-rouge">grid-row-end: span 3</code> means that the end location is <code class="highlighter-rouge">starting grid line</code> + <code class="highlighter-rouge">3 tracks</code>.</p> <p>Below is a CodePen that demonstrates a few different positioning styles. Notice how grid items can overlap. We can use the <code class="highlighter-rouge">z-index</code> property to <a href="https://drafts.csswg.org/css-grid/#z-order">control the stacking order</a>.</p> <p data-height="500" data-theme-id="26435" data-slug-hash="pPKBqB" data-default-tab="css,result" data-user="winkerVSbecks" data-embed-version="2" data-pen-title="CSS Grid Positioning" class="codepen">See the Pen <a href="http://codepen.io/winkerVSbecks/pen/pPKBqB/">CSS Grid Positioning</a> by Varun Vachhar (<a href="http://codepen.io/winkerVSbecks">@winkerVSbecks</a>) on <a href="http://codepen.io">CodePen</a>.</p> <script async="" src="https://production-assets.codepen.io/assets/embed/ei.js"></script> <h2 id="-automate-all-the-things">🤖 Automate All the Things</h2> <p>I want to end by showcasing a couple more concepts through an example. I am going to replicate this <a href="https://www.aldoshoes.com/us/en_US/men/laid-back-loafers">product grid</a> from the Aldo website. A few things to note here:</p> <ul> <li>It is a 4x5 grid on large devices (<code class="highlighter-rouge">&gt; 60em</code>)</li> <li>There are 13 items placed on it</li> <li>Some items span 2 columns and/or 2 rows</li> <li>All images have a ratio of <code class="highlighter-rouge">1000 : 1270</code></li> <li>There is a <code class="highlighter-rouge">1rem</code> gutter and a <code class="highlighter-rouge">1rem</code> padding all around the grid</li> <li>The maximum width of the grid is restricted to <code class="highlighter-rouge">60em</code></li> </ul> <p data-height="500" data-theme-id="26435" data-slug-hash="Gmdwxj" data-default-tab="result" data-user="winkerVSbecks" data-embed-version="2" data-pen-title="Aldo Style Product Grid (CSS Grid)" class="codepen">See the Pen <a href="http://codepen.io/winkerVSbecks/pen/Gmdwxj/">Aldo Style Product Grid (CSS Grid)</a> by Varun Vachhar (<a href="http://codepen.io/winkerVSbecks">@winkerVSbecks</a>) on <a href="http://codepen.io">CodePen</a>.</p> <script async="" src="https://production-assets.codepen.io/assets/embed/ei.js"></script> <p>The grid also changes based on break points. It reduces to 3 columns on medium-sized devices (<code class="highlighter-rouge">30em ↔️ 60em</code>) and 2 columns on small devices <code class="highlighter-rouge">&lt; 30em</code>. Finally, we need to maintain <code class="highlighter-rouge">1000 : 1270</code> ratio between the row and column track sizing.</p> <figure class="center pa0 flex justify-around flex-wrap bg-tertiary"><pre class="mv0 f6 lh-solid code">
Large-Breakpoint
  min-width: 60em
(4 columns)


+-----------+ +-----------+
|  wide 2   | |           |
|           | |           |
+-----------+ |   wide 2  |
+----+ +----+ |   tall 2  |
|    | |    | |           |
|    | |    | |           |
+----+ +----+ +-----------+
+----+ +----+ +----+ +----+
|    | |    | |    | |    |
|    | |    | |    | |    |
+----+ +----+ +----+ +----+
+-----------+ +----+ +----+
|           | |    | |    |
|           | |    | |    |
|  wide 2   | +----+ +----+
|  tall 2   | +----+ +----+
|           | |    | |    |
|           | |    | |    |
+-----------+ +----+ +----+

|&lt;----max-width: 60em----&gt;|</pre><pre class="mv0 f6 lh-solid code">
Medium-Breakpoint
  min-width: 30em
  and max-width: 60em
(3 columns)

+------------------+
|      wide 3      |
|                  |
+------------------+
+-----------+ +----+
|           | |    |
|           | |    |
|  wide 2   | +----+
|  tall 2   | +----+
|           | |    |
|           | |    |
+-----------+ +----+
+----+ +----+ +----+
|    | |    | |    |
|    | |    | |    |
+----+ +----+ +----+
+-----------+ +----+
|           | |    |
|           | |    |
|  wide 2   | +----+
|  tall 2   | +----+
|           | |    |
|           | |    |
+-----------+ +----+
+----+ +----+ +----+
|    | |    | |    |
|    | |    | |    |
+----+ +----+ +----+</pre><pre class="mv0 f6 lh-solid code">
Small-Breakpoint
  min-width: 60em
(2 columns)


+-----------+
|  wide 2   |
|           |
+-----------+
+-----------+
|           |
|           |
|  wide 2   |
|  tall 2   |
|           |
|           |
+-----------+
+----+ +----+
|    | |    |
|    | |    |
+----+ +----+
+----+ +----+
|    | |    |
|    | |    |
+----+ +----+
+----+ +----+
|    | |    |
|    | |    |
+----+ +----+
+-----------+
|           |
|           |
|  wide 2   |
|  tall 2   |
|           |
|           |
+-----------+
+----+ +----+
|    | |    |
|    | |    |
+----+ +----+
+----+ +----+
|    | |    |
|    | |    |
+----+ +----+</pre><figcaption class="clip">The aldo style product grid. 2 columns on small devices, 3 on medium and 4 on large devices.</figcaption> </figure> <h3 id="defining-the-row-and-column-sizes">Defining the Row and Column Sizes</h3> <p>Previously, we used something like <code class="highlighter-rouge">grid-template-columns: repeat(4, 1fr)</code> and <code class="highlighter-rouge">grid-template-rows: repeat(5, 1fr)</code> to generate the grid. Because of the <code class="highlighter-rouge">1000 : 1270</code> ratio we can no longer do that. Instead, we need to use a bit of math to figure out the row and column sizes. For this we can use CSS variables and <code class="highlighter-rouge">calc</code> 🏄 We can calculate the width of the columns and height of the rows using this formula:</p> <div class="language-js highlighter-rouge"><pre class="highlight"><code><span class="nx">width</span> <span class="o">=</span> <span class="p">(</span><span class="nx">width_of_grid</span> <span class="o">-</span> <span class="p">(</span><span class="nx">gutters</span> <span class="o">+</span> <span class="nx">padding</span><span class="p">))</span> <span class="o">/</span> <span class="nx">number_of_columns</span>
<span class="nx">height</span> <span class="o">=</span> <span class="mi">1270</span> <span class="o">*</span> <span class="nx">width</span> <span class="o">/</span> <span class="mi">1000</span>
</code></pre></div> <div class="mv4 overflow-auto"> <table class="mv0 f6 w-100 mw8 center code" cellspacing="0"> <thead> <tr class="striped--light-gray"> <th class="fw6 pa3 bg-white">Break Point</th> <th class="fw6 pa3 bg-white">Width of Grid</th> <th class="fw6 pa3 bg-white">Gutters + Padding</th> <th class="fw6 pa3 bg-white">Number of Columns</th> </tr> </thead> <tbody class="lh-copy"> <tr class="striped--light-gray"> <td class="pa3">Default (less than 30em)</td> <td class="pa3 tc">100vw</td> <td class="pa3 tc">(1 + 2)rem</td> <td class="pa3 tc">2</td> </tr> <tr class="striped--light-gray"> <td class="pa3">min-width: 30em and<br />max-width: 60em</td> <td class="pa3 tc">100vw</td> <td class="pa3 tc">(2 + 2)rem</td> <td class="pa3 tc">3</td> </tr> <tr class="striped--light-gray"> <td class="pa3">min-width: 60em</td> <td class="pa3 tc">60em</td> <td class="pa3 tc">(3 + 2)rem</td> <td class="pa3 tc">4</td> </tr> </tbody> </table> </div> <p>So, for the default case <code class="highlighter-rouge">width = (100vw - 3rem) / 2</code>. Awesome! Let’s put it all together. We start by defining the default value in <code class="highlighter-rouge">:root</code>. Then at each break point we recalculate <code class="highlighter-rouge">width</code> and update the <code class="highlighter-rouge">grid-template-columns</code> property.</p> <div class="language-css highlighter-rouge"><pre class="highlight"><code><span class="nd">:root</span> <span class="p">{</span>
  <span class="py">--width</span><span class="p">:</span> <span class="n">calc</span><span class="p">(</span> <span class="p">(</span><span class="m">100vw</span> <span class="n">-</span> <span class="m">3rem</span><span class="p">)</span> <span class="p">/</span> <span class="m">2</span> <span class="p">);</span>
  <span class="py">--height</span><span class="p">:</span> <span class="n">calc</span><span class="p">(</span> <span class="m">1270</span> <span class="err">*</span> <span class="n">var</span><span class="p">(</span><span class="n">--width</span><span class="p">)</span> <span class="p">/</span> <span class="m">1000</span> <span class="p">);</span>
<span class="p">}</span>

<span class="nc">.layout</span> <span class="p">{</span>
  <span class="py">grid-gap</span><span class="p">:</span> <span class="m">1rem</span><span class="p">;</span>
  <span class="py">grid-template-columns</span><span class="p">:</span> <span class="nb">repeat</span><span class="p">(</span> <span class="m">2</span><span class="p">,</span> <span class="n">var</span><span class="p">(</span><span class="n">--width</span><span class="p">)</span> <span class="p">);</span>
  <span class="py">grid-auto-rows</span><span class="p">:</span> <span class="n">var</span><span class="p">(</span><span class="n">--height</span><span class="p">);</span>
<span class="p">}</span>

<span class="k">@media</span> <span class="n">screen</span> <span class="n">and</span> <span class="p">(</span><span class="n">min-width</span><span class="p">:</span> <span class="m">30em</span><span class="p">)</span> <span class="n">and</span> <span class="p">(</span><span class="n">max-width</span><span class="p">:</span> <span class="m">60em</span><span class="p">)</span> <span class="p">{</span>
  <span class="nd">:root</span> <span class="p">{</span> <span class="py">--width</span><span class="p">:</span> <span class="n">calc</span><span class="p">(</span> <span class="p">(</span><span class="m">100vw</span> <span class="n">-</span> <span class="m">4rem</span><span class="p">)</span> <span class="p">/</span> <span class="m">3</span> <span class="p">);</span> <span class="p">}</span>
  <span class="nc">.layout</span> <span class="p">{</span> <span class="py">grid-template-columns</span><span class="p">:</span> <span class="nb">repeat</span><span class="p">(</span> <span class="m">3</span><span class="p">,</span> <span class="n">var</span><span class="p">(</span><span class="n">--width</span><span class="p">)</span> <span class="p">);</span> <span class="p">}</span>
<span class="p">}</span>

<span class="k">@media</span> <span class="n">screen</span> <span class="n">and</span> <span class="p">(</span><span class="n">min-width</span><span class="p">:</span> <span class="m">60em</span><span class="p">)</span> <span class="p">{</span>
  <span class="nd">:root</span> <span class="p">{</span> <span class="py">--width</span><span class="p">:</span> <span class="n">calc</span><span class="p">(</span> <span class="p">(</span><span class="m">60em</span> <span class="n">-</span> <span class="m">5rem</span><span class="p">)</span> <span class="p">/</span> <span class="m">4</span> <span class="p">);</span> <span class="p">}</span>
  <span class="nc">.layout</span> <span class="p">{</span> <span class="py">grid-template-columns</span><span class="p">:</span> <span class="nb">repeat</span><span class="p">(</span> <span class="m">4</span><span class="p">,</span> <span class="n">var</span><span class="p">(</span><span class="n">--width</span><span class="p">)</span> <span class="p">);</span> <span class="p">}</span>
<span class="p">}</span>
</code></pre></div> <h3 id="auto-rows">Auto Rows</h3> <p>In the code snippet above you might have noticed <code class="highlighter-rouge">grid-auto-rows: var(--height)</code>. This tells the browser to automatically generate just enough rows to fit all the items. So if we add more items, it will add more rows and vice versa. The value for <code class="highlighter-rouge">grid-auto-rows</code> is what we want the height of the row to be.</p> <p>The CodePen below demonstrates what the grid would look like at this point. Open it in the <a href="http://codepen.io/winkerVSbecks/pen/dWjjWw">edit mode</a> to see how the resizing works and what happens when you add or remove items.</p> <p data-height="300" data-theme-id="26435" data-slug-hash="dWjjWw" data-default-tab="result" data-user="winkerVSbecks" data-embed-version="2" data-pen-title="Aldo Style Product Grid (CSS Grid) STEP 1 for blogpost" class="codepen">See the Pen <a href="http://codepen.io/winkerVSbecks/pen/dWjjWw/">Aldo Style Product Grid (CSS Grid) STEP 1 for blogpost</a> by Varun Vachhar (<a href="http://codepen.io/winkerVSbecks">@winkerVSbecks</a>) on <a href="http://codepen.io">CodePen</a>.</p> <script async="" src="https://production-assets.codepen.io/assets/embed/ei.js"></script> <p>📝 Did you notice that we did not have to place the items on the grid?! If you don’t specify positioning then the browser automatically places items on the grid. This is known as <a href="https://developer.mozilla.org/en-US/docs/Web/CSS/grid-auto-flow">auto flow</a>.</p> <h3 id="item-spans-️">Item Spans ↔️</h3> <p>As I mentioned earlier, some items span multiple tracks. For this we can use the <code class="highlighter-rouge">grid-&lt;row|column&gt;-end: span &lt;number&gt;</code> technique. The span size for the images remains the same across all break points. However, the product info spans 3 columns on medium-sized devices and 2 columns for all other breakpoints. Therefore, we apply <code class="highlighter-rouge">wide-2 wide-3-m</code> to it. The other items use <code class="highlighter-rouge">wide-2 tall-2</code>.</p> <div class="language-css highlighter-rouge"><pre class="highlight"><code><span class="nc">.wide-2</span> <span class="p">{</span> <span class="py">grid-column-end</span><span class="p">:</span> <span class="n">span</span> <span class="m">2</span><span class="p">;</span> <span class="p">}</span>
<span class="nc">.tall-2</span> <span class="p">{</span> <span class="py">grid-row-end</span><span class="p">:</span> <span class="n">span</span> <span class="m">2</span><span class="p">;</span> <span class="p">}</span>

<span class="k">@media</span> <span class="n">screen</span> <span class="n">and</span> <span class="p">(</span><span class="n">min-width</span><span class="p">:</span> <span class="m">30em</span><span class="p">)</span> <span class="n">and</span> <span class="p">(</span><span class="n">max-width</span><span class="p">:</span> <span class="m">60em</span><span class="p">)</span> <span class="p">{</span>
  <span class="nc">.wide-3-m</span> <span class="p">{</span> <span class="py">grid-column-end</span><span class="p">:</span> <span class="n">span</span> <span class="m">3</span><span class="p">;</span> <span class="p">}</span>
<span class="p">}</span>
</code></pre></div> <p data-height="500" data-theme-id="26435" data-slug-hash="vmazxG" data-default-tab="result" data-user="winkerVSbecks" data-embed-version="2" data-pen-title="Aldo Style Product Grid (CSS Grid) STEP 2 for blogpost" class="codepen">See the Pen <a href="http://codepen.io/winkerVSbecks/pen/vmazxG/">Aldo Style Product Grid (CSS Grid) STEP 2 for blogpost</a> by Varun Vachhar (<a href="http://codepen.io/winkerVSbecks">@winkerVSbecks</a>) on <a href="http://codepen.io">CodePen</a>.</p> <script async="" src="https://production-assets.codepen.io/assets/embed/ei.js"></script> <blockquote> <p>Want to learn more about auto placement? Check out Rachel Andrew’s fantastic <a href="http://gridbyexample.com/video/series-auto-placement-span">tutorial</a> and <a href="http://codepen.io/rachelandrew/pen/LRWPNp">demo</a>.</p> </blockquote> <h3 id="dense-packing">Dense Packing</h3> <p>We have a grid. We used auto placement to position items and some items span multiple columns &amp; rows. So we’re done? Not quite. If you inspect the above CodePen in <a href="http://codepen.io/winkerVSbecks/pen/vmazxG">edit mode</a> you will notice that the grid ends up with <em>holes</em> at certain break points.</p> <p><img src="/img/grid-holes.png" alt="holes in the grid" /></p> <p>This is because by default auto placement uses a <em>sparse</em> packing algorithm which can lead to <em>holes</em> in the layout. The good news is that we can switch to a <em>dense</em> packing algorithm which causes the browser to backtrack and fill any empty cells in the layout <img src="/img/parrot.gif" alt="party parrot" style="display:inline !important; width: 1em !important;" /></p> <div class="language-diff highlighter-rouge"><pre class="highlight"><code>.layout {
  grid-gap: 1rem;
<span class="gi">+ grid-auto-flow: dense;
</span>  grid-template-columns: repeat(2, var(--width));
  grid-auto-rows: var(--height);
}
</code></pre></div> <p>That’s it! Below is the final version. And here’s <a href="https://winkervsbecks.github.io/grid-experiments/vinyl">another example</a> that uses auto layout and dense packing to display music albums.</p> <p data-height="500" data-theme-id="26435" data-slug-hash="Gmdwxj" data-default-tab="result" data-user="winkerVSbecks" data-embed-version="2" data-pen-title="Aldo Style Product Grid (CSS Grid)" class="codepen">See the Pen <a href="http://codepen.io/winkerVSbecks/pen/Gmdwxj/">Aldo Style Product Grid (CSS Grid)</a> by Varun Vachhar (<a href="http://codepen.io/winkerVSbecks">@winkerVSbecks</a>) on <a href="http://codepen.io">CodePen</a>.</p> <script async="" src="https://production-assets.codepen.io/assets/embed/ei.js"></script> <div class="mb5 tc sans-serif flex db-ns"> <a class="f6 bg-secondary ph3 pv2 w4 dib flex-auto mr3" href="https://winkervsbecks.github.io/grid-experiments"> Demo </a> <a class="f6 bg-secondary ph3 pv2 w4 dib flex-auto" href="https://github.com/winkerVSbecks/grid-experiments"> Source </a> </div> <h2 id="conclusion">Conclusion</h2> <p>Take a moment to think about the possibilities 🤔 Think of all the crazy layouts we can build now. Can’t think of any? Not a problem. Hop on over to Jen Simmons’s <a href="http://labs.jensimmons.com">Layout Lab</a> for some ideas. CSS Grids will likely have a drastic impact on web design. All those layouts you abandoned because they were not possible with CSS will likely be possible thanks to CSS Grids.</p> <p>What Next? Did you know you can name grid lines? Did you know you can align items in a track using <code class="highlighter-rouge">align</code> and <code class="highlighter-rouge">justify</code> properties? Did you know you can specify sizes as a range using <code class="highlighter-rouge">minmax</code>? There is so much more to discover! I know it can feel a bit overwhelming. Take little steps. Build things. Experiment. It’s okay to not understand everything at once.</p> <h5>Further Reading</h5> <ul> <li class="mb2"> <a href="http://gridbyexample.com">Grid by Example</a> </li> <li class="mb2"> <a href="http://jonibologna.com/spring-into-css-grid">Spring Into CSS Grid 🌼</a> </li> <li class="mb2"> <a href="https://developer.mozilla.org/en-US/docs/Web/CSS/CSS_Grid_Layout/Basic_Concepts_of_Grid_Layout">Basic concepts of grid layout – MDN</a> </li> <li class="mb2"> <a href="https://drafts.csswg.org/css-grid">CSS Grid Spec</a> </li> </ul> </div> <!-- end of post content --> <div class="mt5"> <a href="https://twitter.com/share" class="twitter-share-button" data-via="winkerVSbecks" data-size="large">Tweet</a> </div> </article> <div class="mw7 center ph3"> <aside class="pv4 dark-gray bt bw1 b--light-gray"> <h1 class="f4">Related Posts</h1> <ul class="pl4"> <li> <a href="http://varun.ca/rebase/" class="link dim near-black db f5 f4-ns pv2" title="Git Rebase"> Git Rebase <date class="f6 gray" datetime="2017-03-01 00:00:00 +0000"> 1st March, 2017 </date> </a> </li> <li> <a href="http://varun.ca/icon-component/" class="link dim near-black db f5 f4-ns pv2" title="Component based SVG Icon System"> Component based SVG Icon System <date class="f6 gray" datetime="2017-02-11 00:00:00 +0000"> 11th February, 2017 </date> </a> </li> <li> <a href="http://varun.ca/touch-and-mouse-together/" class="link dim near-black db f5 f4-ns pv2" title="Touch and Mouse Together"> Touch and Mouse Together <date class="f6 gray" datetime="2016-11-15 00:00:00 +0000"> 15th November, 2016 </date> </a> </li> </ul> </aside> <footer class="pt3 pt6-ns mb6 system-sans "> <ul class="list pl0 mb3"> <li class="dib mr3"> <a title="about varun vachhar" class="db b f6 tracked link dim dark-gray" href="http://varun.ca/"> About </a> </li> <li class="dib"> <a title="writing about JavaScript, CSS and reactive animations." class="db b f6 tracked link dim dark-gray" href="http://varun.ca/writing"> Writing </a> </li> </ul> <ul class="list pl0 db"> <li class="dib mr3"> <a class="db f6 link dim dark-gray" title="varun vachhar on twitter" href="http://twitter.com/winkerVSbecks"> Twitter </a> </li> <li class="dib mr3"> <a class="db f6 link dim dark-gray" title="varun vachhar on github" href="http://github.com/winkerVSbecks"> Github </a> </li> <li class="dib mr3"> <a class="db f6 link dim dark-gray" title="varun vachhar on CodePen" href="http://codepen.io/winkerVSbecks"> CodePen </a> </li> <li class="dib mr3"> <a class="db f6 link dim dark-gray" title="varun vachhar on dribbble" href="http://dribbble.com/winkerVSbecks"> Dribbble </a> </li> <li class="dib mr3"> <a class="db f6 link dim dark-gray" title="email varun vachhar" href="mailto:varunvachhar@gmail.com"> Email </a> </li> </ul> </footer> </div> <script>window.twttr = (function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0], t = window.twttr || {}; if (d.getElementById(id)) return t; js = d.createElement(s); js.id = id; js.src = "https://platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs); t._e = []; t.ready = function(f) { t._e.push(f); }; return t; }(document, "script", "twitter-wjs"));</script> <script> function _toConsumableArray(arr) { if (Array.isArray(arr)) { for (var i = 0, arr2 = Array(arr.length); i < arr.length; i++) { arr2[i] = arr[i]; } return arr2; } else { return Array.from(arr); } } var headingQuery = 'h2[id],h3[id],h4[id],h5[id],h6[id]'; var headings = document.querySelectorAll(headingQuery); [].concat(_toConsumableArray(headings)).forEach(function (heading) { heading.innerHTML = '<a href="#' + heading.id + '" class="link" style="color: inherit;"> ' + heading.innerText + ' </a>'; }); </script> <script> (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','https://www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-22315045-9', 'auto'); ga('send', 'pageview'); </script> </body> </html>
